Board is done but no joy when button is pressed.

Forum for the discussion of building and moding the ProDEV DDT debugger boards

Moderator: support

Board is done but no joy when button is pressed.

Postby support » Wed Aug 24, 2005 3:31 pm

Any ideas where to start trouble shooting?
support
Site Admin
 
Posts: 169
Joined: Tue Mar 08, 2005 10:49 pm
Location: Ajax, On, Canada

Postby ProDev » Fri Aug 26, 2005 9:40 am

Enter the system monitor.

do Cn00G where n is the slot number where the DDT card is installed.

You should see the main debug screen.

If you do not:

Check all the solder connections. (It's easy to miss one)
Make sure there are no bent leads on any of the ICs.
Make sure the card's edge connector is clean, solder flux is hard to see. Use an eraser and very gently clean the edge connector if it looks suspect.
The same is true for the IC sockets, solder flux will prevent a good connection with the IC. I use a 90+% solution of Isopropyl Alcohol, you can buy it in any drug store. The ICs need to be out of the sockets. I completely submerse the board in alcohol and scrub the solder flux residue off with a stiff brush then let the board air dry. Do this in a well ventillated area away from any open flames. (duh)

On a IIGS the button is not enabled until the DDT card has been initialized. I've got a program that initialized the DDT card automatically on boot up but I think I forgot to put it on my web site. I'll check. Note! On the IIGS the DDT must be in slots 4,5,6 or 7.

The button generates an NMI and should only be used to interrupt a running program. A more controlled way of debugging progams is to use breakpoints.
Chuck
ProDev
 
Posts: 12
Joined: Thu Jun 23, 2005 8:46 pm
Location: La Salle, MI

OK

Postby support » Fri Aug 26, 2005 5:58 pm

Well there's a few items i missed

Monitor init and slot placement for the IIgs.

I should know better - RTFM.

It looks to be working when I press the button.

Now to spend some QT with it.


Thanks

Glenn
support
Site Admin
 
Posts: 169
Joined: Tue Mar 08, 2005 10:49 pm
Location: Ajax, On, Canada

Help w/ debug on dead card

Postby shirsch » Sat Jul 12, 2008 6:55 am

Hi, all. Finally got around to building a DDT16 from the kit. Unfortunately, it is not operational. No smoke or flames, but entering the monitor and typing, e.g. C700G, just hangs. I've tried a couple of different slots with no better luck. The EPROM verifies fine against the binary and I've double and triple checked for bad or missing solder connections, misaligned chip pins, etc.

Where do I start trying to figure this out? From the Apple side, the slot ROM appears in the correct place and data looks correct. I'm guessing that it's going south when the CPU bank register is hit. What part of the hardware deals with this? Any tips appreciated!
shirsch
 
Posts: 4
Joined: Fri Jul 11, 2008 10:45 am

Postby support » Wed Jul 16, 2008 10:00 am

Hi Steve, sorry I don't have any suggestions for you ... have you tried contcating Chuck directly?
support
Site Admin
 
Posts: 169
Joined: Tue Mar 08, 2005 10:49 pm
Location: Ajax, On, Canada

Postby shirsch » Mon Jul 21, 2008 8:02 pm

support wrote:Hi Steve, sorry I don't have any suggestions for you ... have you tried contcating Chuck directly?


No, I haven't. Is it still 'info@prodev.biz'? That's the only thing I could find.
shirsch
 
Posts: 4
Joined: Fri Jul 11, 2008 10:45 am

Postby support » Mon Jul 21, 2008 8:05 pm

He registered with check@prodev.biz ... Thats what I had I think ...
support
Site Admin
 
Posts: 169
Joined: Tue Mar 08, 2005 10:49 pm
Location: Ajax, On, Canada

Postby shirsch » Tue Jul 22, 2008 6:37 am

support wrote:He registered with check@prodev.biz ... Thats what I had I think ...


Um, is that supposed to be 'chuck'? You wrote 'check'...
shirsch
 
Posts: 4
Joined: Fri Jul 11, 2008 10:45 am

Postby support » Tue Jul 22, 2008 9:17 am

Sorry yes that was supposed to be Chuck
support
Site Admin
 
Posts: 169
Joined: Tue Mar 08, 2005 10:49 pm
Location: Ajax, On, Canada


Return to DDT Build and Mod

Who is online

Users browsing this forum: No registered users and 1 guest

cron